Status - Versandstatus wird falsch angezeigt

Avatar
  • aktualisiert
  • working on it

Moin zusammen,
wir haben ein Problem mit der Statusanzeige.
Obwohl alle Artikel versendet wurden, wir das Icon nur als "teilweise versendet" angezeigt.
Das Problem ist möglicherweise das ein Artikel doppelt eingegeben wurde (Gratiszugabe mit 100%).
Der Auftrag hat somit 4 Pos. laut Sendungsstatus aber nur 3 Pos. versendet, jedoch mit der vollständigen Menge. (Pos 3 und 4 wurden zu einer Pos. zusammengeführt)
Anbei ein paar Bilder zum Beispiel.

Gruß
Nico

Wie häufig tritt der Fehler auf?:
Bei wie vielen Anwendern tritt der Fehler auf?:
Tritt der Fehler in verschiedenen Browsern auf?:
Tritt der Fehler in verschiedenen Betriebssystemen auf?:
Im Falle eines Bugs: In welchem Browsern und Betriebssystemen tritt der Fehler auf?:
Release geplant mit:
Avatar
Ernest | Elements
  • working on it

Hallo Nico,

vielen Dank für deinen Hinweis. Ich habe mir die Bestellung inklusive aller Belege einmal angesehen.

Wie du schon schreibst, sollte der Status auf "komplett versendet" stehen, da alle Artikel versendet worden sind. Leider "berücksichtigen" wir aktuell bei der Ermittlung des Status auch Positionen, die kein Artikel sind. In deinem Beispiel ist das die Textposition, die enthalten ist. Wir werden das im Zuge eines größeren Umbaus der Statusermittlung in einem der nächsten Updates berücksichtigen.

Im Zuge dieses Umbaus wird dann auch aus dem Status ersichtlich sein, ob der Vorgang abgeschlossen ist oder nicht. Kleiner Hinweis von mir: In deinem Beispiel bleibt der kostenlos versendete Artikel auf immer und ewig "nicht erfüllt", da ihm die Berechnung fehlt. Somit bleibt auch der Verkaufsvorgang nicht erfüllt. Somit wird diese Bestellung auch in ELEMENTS nach dem Umbau immer als "offene Bestellung" angezeigt werden. Sprich doch bitte einmal mit deinem ERP-Betreuer, ob derartige Verkaufsvorgänge automatisch "erfüllt" werden können.

Schöne Grüße,
Ernest